instead of int + negative_utc boolean
The plan:
- Add offset_bytes attribute to TimestampWithTimezone, fill it from offset and negative_utc if not provided
- Make offset and negative_utc optional (fill the attributes from offset_bytes)
- Raise DeprecationWarning when they are passed to the constructor (but from_dict should not raise it)
- Remove explicit uses in the constructor (track down deprecation warnings)
- Remove use of negative_utc (there is one in swh-web/swh/web/common/converters.py)
- Remove them from the constructor (but not from_dict, because kafka), remove offset and negative_utc entirely
Rename offset_bytes to offset
Postgresql must be migrated somewhere between 1 and 6 (exclusive). Kafka does not need to be migratet as long as we keep the compat in from_dict methods.