Page MenuHomeSoftware Heritage

Get rid of the concept of vault "object_type"
Closed, ResolvedPublic

Description

It's loosely defined based on the object-as-in-swh.model type (eg. "directory", "revision") and bundle type ("gitfast", "git_bare"), so we had eg. "directory", "revision_flat", "revision_git_bare", etc.

Instead, replace it with just a "bundle_type" (flat, gitfast, git_bare), and identify objects with a SWHID instead of a bare sha1_git