Page MenuHomeSoftware Heritage

Timeout reached while assembling the requested bundle (Rocrail)
Closed, ResolvedPublic

Description

Hi,

today, I wanted to obtain a copy of Rocrail (formerly licensed under the GPL, now
closed source).

https://archive.softwareheritage.org/browse/origin/https://github.com/rocrail/Rocrail/directory/

Unfortunately, I received the following error:

You have requested the following bundle from the Software Heritage
Vault:

Object Type: revision_gitfast
Object ID: 85678b0d6c52d6fd0af50c8e493c74dd15a7115d

This bundle could not be cooked for the following reason:

Timeout reached while assembling the requested bundle

We apologize for the inconvenience.

-- 
The Software Heritage Developers

Anything you can do about this? I'd love to get a copy (git repo) of that project.

Thanks,
Mike

Event Timeline

sunweaver created this object in space S1 Public.

I don't reproduce this error.

zack triaged this task as Normal priority.Aug 23 2019, 8:52 AM
zack added a project: Vault.
zack added a subscriber: zack.Aug 23 2019, 9:23 AM

I can totally reproduce this issue.

Mike: apologies, the gitfast download isn't really reliable ATM. However, I managed to find the most recent commit where the top-level license file was still GPL and cook it with the directory downloader. It's available here: https://archive.softwareheritage.org/api/1/vault/directory/d9d76591c8adc41d1c1ab9b7bc4d880653955d84/raw (You can also re-cook it yourself, it will either hit the cache or prepare it again, which should work.)

I hope this is enough to solve your immediate need. We'll keep this task open for the general unreliability of the gitfast downloader.

zack added a comment.Aug 23 2019, 10:59 AM

@sunweaver: did you see my answer above?

@zack: Thanks for providing the tarball. However, I in fact need a tarred up Git repo until the moment that GPL was revoked, as I want to re-pulish it via GitLab (or Github). Do you think it is possible to get a copy of that git repo any time soon?

@zack: the point about rocrail is that GPL was revoked without copyright holders' consent. And there is no most recent version public anymore these days.

zack added a comment.Aug 23 2019, 2:29 PM

@zack: Thanks for providing the tarball. However, I in fact need a tarred up Git repo until the moment that GPL was revoked, as I want to re-pulish it via GitLab (or Github). Do you think it is possible to get a copy of that git repo any time soon?

I think so, yes, we'll do it ad-hoc for you.

zack added a subscriber: seirl.EditedSep 18 2019, 3:10 PM

So, this is now actually working (@rdicosmo just tried it again) *but* the bundle stops being assembled shortly before finishing due to a maximum size limit of ~500 MB:

You have requested the following bundle from the Software Heritage
Vault:

Object Type: revision_gitfast
Object ID: 85678b0d6c52d6fd0af50c8e493c74dd15a7115d

This bundle could not be cooked for the following reason:

The requested bundle exceeds the maximum allowed size of 536870912 bytes.

@seirl: can you bump the limit to, say, 1 GB ? That will most definitely be enough for this case, will help in many others, and it doesn't seem too crazy to have.

zack added a subscriber: rdicosmo.Sep 18 2019, 3:10 PM
olasd added a subscriber: olasd.Sep 18 2019, 6:21 PM

I've bumped the limit to 1GB and sent a cook request again.

zack closed this task as Resolved.EditedSep 19 2019, 12:18 PM
zack claimed this task.

@sunweaver: the bundle is ready, in theory you should be able to obtain it like this:

$ wget https://archive.softwareheritage.org/api/1/vault/revision/85678b0d6c52d6fd0af50c8e493c74dd15a7115d/gitfast/raw/ -O 85678b0d6c52d6fd0af50c8e493c74dd15a7115d.gitfast.gz
$ git init
$ zcat 85678b0d6c52d6fd0af50c8e493c74dd15a7115d.gitfast.gz | git fast-import

I say in theory because (due to T885) download of large bundles is a bit flaky right now.

But we do have the bundle ready, it's "just" a streaming problem to retrieve it from the outside. So if you have trouble downloading, just let us know here and we'll make it available to you by some other means.

Hi Zack,

The previous mail reply got truncated...

The download process is stuck with this...

[mike@minobo rocrail-upstream]$ wget https://archive.softwareheritage.org/api/1/vault/revision/85678b0d6c52d6fd0af50c8e493c74dd15a7115d/gitfast/raw/ -O 85678b0d6c52d6fd0af50c8e493c74dd15a7115d.gitfast.gz
--2019-09-19 12:40:44--  https://archive.softwareheritage.org/api/1/vault/revision/85678b0d6c52d6fd0af50c8e493c74dd15a7115d/gitfast/raw/
Resolving archive.softwareheritage.org (archive.softwareheritage.org)... 128.93.193.31
Connecting to archive.softwareheritage.org (archive.softwareheritage.org)|128.93.193.31|:443... connected.
HTTP request sent, awaiting response...

Mike