- User Since
- Feb 2 2017, 11:38 AM (208 w, 5 h)
Fri, Jan 8
Rebase on master, include webgraph files
I'm realizing that this is missing the "simplified" step and needs more changes.
Add task name to commit message
Thu, Jan 7
Wed, Jan 6
Tue, Jan 5
Dec 17 2020
Dec 16 2020
Dec 15 2020
Landed, but phabricator doesn't seem to see it.
- journalprocessor: remove comment about deserialize_message overload being a 'hack'
- journalprocessor: also partition sqlite files by first byte
- SQLite on-disk set: disable journalling and synchronous mode
- tests: fix test_export_origin
Dec 14 2020
Dec 11 2020
- Exporter documentation fixes
- Journal processor: fetch offsets in parallel
Fix various coding errors and minor improvements
Better commit message:
Dec 10 2020
Dec 9 2020
Dec 8 2020
Subscribe to the correct objects
Fix variable name
My API idea was to simply have something like ENTRIES_REGEXP = r'^.*:.*$' as a class attribute of each type of directory, and a validate_entry(self, name: str) method which, by default, just checks that it matches the regexp.
Dec 3 2020
We also need to discuss what exactly we put in cache/. I thought about symlinks to archive/ and meta/, what do you think? Removing the symlinks also means removing the data from the cache.
Dec 2 2020
Dec 1 2020
Nov 27 2020
Nov 25 2020
Nov 20 2020
Nov 19 2020
Nov 18 2020
Nov 16 2020
Nov 13 2020
Nov 12 2020
I think I understand what your fill_direntry_cache function is trying to do: you want to avoid fetching the history multiple times by doing the request only once and writing the direntry cache of all the children recursively?
Would it be maybe better to instead have a small LRU cache for the API queries, and keep the direntry code simple and fully lazy?
Nov 5 2020
Nov 4 2020
Looks good apart from two small things.
Nov 3 2020
One thing I don't really like here is that FuseEntries cannot easily list their own entries easily using the cache when available. I would much rather have the cache logic moved inside FuseEntry like what we discussed.
Oct 22 2020
Oct 21 2020
Oct 16 2020
Oct 14 2020
Oct 13 2020
lookup() should ideally be O(1).
Oct 12 2020
Oct 9 2020
Oct 8 2020
Oct 7 2020
Oct 6 2020
This is looking pretty great. I see three more good refactoring possibilities:
Oct 5 2020
Fix BVGraph/ImmutableGraph implicit naming
Oct 3 2020
Yes, the correct method name is enter_context