Page MenuHomeSoftware Heritage

Improve handling of GitLab origins in Save Code Now requests
Closed, ResolvedPublic

Description

The logic for filtering bad requests for Save Code Now needs to be improved to handle the fact that GitLab allows subprojects.
For example, https://gitlab.inria.fr/solverstack/maphys/maphys/ is a legitimate origin, but it is flagged as invalid by the WebApp for the moment.

Event Timeline

rdicosmo triaged this task as Normal priority.Mar 24 2020, 11:42 AM
rdicosmo created this task.
rdicosmo reopened this task as Open.Mar 25 2020, 6:35 PM

It looks like the patch only fixes the issue for the gitlab.com origin, while the issue is present in all origins that are instances of GitLab, like https://gitlab.inria.fr/solverstack/maphys/maphys/

olasd added a subscriber: olasd.Mar 25 2020, 6:40 PM

The patch only adds a test for an origin url under gitlab.com, but the regular expression change actually allows multiple levels of directories for any origin.

anlambert closed this task as Resolved.Mar 25 2020, 6:41 PM

The patch hopefully fixes all type of git repository urls. I think you got mistaken by the frontend test, the real fix is in the regexp modification.
Nervertheless, this is not deployed yet.