Page MenuHomeSoftware Heritage

Fix badges for SWHAP with .svn extension
Closed, ResolvedPublic

Description

Possibly by creating badge link with .svn extension
@anlambert would it be possible to have an additional link to a badge with .svn extension?
https://archive.softwareheritage.org/badge/origin/https://github.com/Unipisa/TAUmus/badge.svn
the same way it replies to
https://archive.softwareheritage.org/badge/origin/https://github.com/Unipisa/TAUmus/
Will this resolve the issue?

@scatenag thinks the problem is that we have not a link to an image (Eg. image.svg)
This causes latex to fail.

In search of a solution for a fails with latex compiler:

https://github.com/SoftwareHeritage/swhapguide/tree/badges

Event Timeline

moranegg triaged this task as Normal priority.Dec 14 2019, 12:54 AM
moranegg created this task.

Maybe "This might be resolved with T2146 ?" - T2149 is this one :)...
Anyway .. No, even if T2146 is resolved, this is unrelated.
Actually the link in this issue https://archive.softwareheritage.org/badge/origin/https://github.com/Unipisa/TAUmus/ was already correctly responding .. as the software was already archived...


Actually, the problem is related on how to include badges in latex.
I mean: in the swapguide we edit a .md and it will become readable via github we interface (here everithing is ok).
But .. we generate alse a latex file where the image

[![SWH](https://archive.softwareheritage.org/badge/origin/https://github.com/Unipisa/TAUmus)](https://archive.softwareheritage.org/browse/origin/https://github.com/Unipisa/TAUmus/)

becomes

\href{https://archive.softwareheritage.org/browse/origin/https://github.com/Unipisa/TAUmus/}{\includegraphics{https://archive.softwareheritage.org/badge/origin/https://github.com/Unipisa/TAUmus}}

The problem is that the latex compiler doesnt find andy "file" at the url even if is there..
for this reason I suggested to serve also a badge.svg file to help those situations...

but .. again it is a latex&badges problem, not a swh problem .. so you I can mark this as resolved ..

scatenag closed this task as Resolved.Dec 16 2019, 10:10 AM