Page MenuHomeSoftware Heritage

create a jenkins job to build and publish the sphinx documentation
Closed, ResolvedPublic

Event Timeline

douardda created this task.Oct 8 2018, 2:53 PM
douardda triaged this task as High priority.
douardda closed this task as Resolved.Nov 5 2018, 11:12 AM

The jenkins job that builds the doc seems to run OK and the publish by ssh post-action seems to work also, so we could consider this task as done, however this adds a small regression due to the way this jenkins plugin works (ie. 'rm *' before starting to scp files), there is a 5 to 10s period, when the published content is partial and may result in 404.

I suggest to call it good as is, and set a proper solution up if and only if it really obviously cause problems...

zack added a subscriber: zack.Nov 5 2018, 12:37 PM

I suggest to call it good as is, and set a proper solution up if and only if it really obviously cause problems...

That's fine for me. Can you maybe file a low/wishlist priority bug report to keep track of this?

(The right solution is probably to have a symlink pointing to the dir of the published doc, build the updated doc in a new tempdir, and atomically switch the link at the end of the build. But I agree the lack of this shouldn't be considered a blocker for T1249.)