- Add a listing of Python dependencies needed for the tests
- Add a canonical way to environment variables for the tests
- Use logging to record tests progression
- Raise timeouts for replaying, shut down and storage access
- Use a dedicated network for Docker swarm
- Remove an unused Docker image from the generation process
- Add troubleshooting tips to the test documentation
Details
- Reviewers
ardumont - Group Reviewers
Reviewers - Commits
- rCDFPe686e974db23: Add troubleshooting tips to the test documentation
rCDFP2e9b484c147c: Remove an unused Docker image from the generation process
rCDFPe80c1374575d: Raise timeouts for replaying, shut down and storage access
rCDFP5e681aedf4db: Use a dedicated network for Docker swarm
rCDFP691f49d3045b: Use logging to record tests progression
rCDFPdc32dcdc1c92: Add a canonical way to environment variables for the tests
rCDFPf09e49ecf526: Add a listing of Python dependencies needed for the tests
Diff Detail
- Repository
- rCDFP Deployment tools for hosting a mirror
- Branch
- master
- Lint
No Linters Available - Unit
No Unit Test Coverage - Build Status
Buildable 31842 Build 49830: arc lint + arc unit
Event Timeline
lgtm
one non-blocking suggestion inline.
tests/test_graph_replayer.py | ||
---|---|---|
326 | not on you. Still, would be best to let the log instruction do the formatting (instead of f-strings). |
tests/test_graph_replayer.py | ||
---|---|---|
326 | Could you explain your rationale? Is it because of extra computation costs if logging is disabled? I find f-strings more readable than other interpolation format so I favored legibility over minor gains in CPU cycles in this case. |
tests/test_graph_replayer.py | ||
---|---|---|
326 | It's about the logging level you set yes. But also about uniformisation in the base If you look at any of our other modules, you'll see we do use f-string for some string Also it happens also that some objects (SWHID comes to mind but i may be wrong) used in |
tests/test_graph_replayer.py | ||
---|---|---|
326 | Although now that i've said that and given that I re-realized it's test code, it may be fine to keep it that way. To be clear, it's non-blocking otherwise i would have requested changes btw. |