Page MenuHomeSoftware Heritage

Fix psycopg2 warning flooding the output.
ClosedPublic

Authored by vlorentz on Dec 17 2018, 3:06 PM.

Details

Summary

There's one message every 10 seconds...

Diff Detail

Repository
rCDFD Dockerfiles for developers
Branch
psycopg-warning
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 3094
Build 3954: arc lint + arc unit

Event Timeline

vlorentz created this revision.Dec 17 2018, 3:06 PM
olasd added a subscriber: olasd.Dec 17 2018, 3:19 PM

Doesn't that need libpq-dev installed in the container?

In D836#17872, @olasd wrote:

Doesn't that need libpq-dev installed in the container?

It does, but thankfully, libpq-dev is already installed in the container:

i   mercurial          Suggests qct                               
p   qct                Depends  python-qt4                        
p   python-qt4         Depends  libqt4-declarative (>= 4:4.8.0-1~)
p   libqt4-declarative Depends  libqt4-sql (= 4:4.8.7+dfsg-11)    
p   libqt4-sql         Suggests libqt4-dev                        
p   libqt4-dev         Suggests libpq-dev

I'd better install it explicitly, though.

vlorentz updated this revision to Diff 2662.Dec 17 2018, 3:34 PM
  • explicitly install lipq-dev.
ardumont accepted this revision.Dec 17 2018, 4:10 PM
ardumont added a subscriber: ardumont.

Only from workers?

Don't we want that in other modules as well?

(I did not look what that error was about)

This revision is now accepted and ready to land.Dec 17 2018, 4:10 PM

Yeah, but for other modules it's a single line when starting.

This revision was automatically updated to reflect the committed changes.