Page MenuHomeSoftware Heritage

Upgrade hedgedoc to 1.9.0
ClosedPublic

Authored by olasd on Sep 15 2021, 5:24 PM.

Details

Summary

Needs the following changes as well:

  • Update expired yarn public key
  • Add apt source configuration for nodejs LTS 14.x

Related to T3574

Test Plan

tested the (unattended) upgrade procedure in vagrant

Diff Detail

Repository
rSPSITE puppet-swh-site
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

olasd requested review of this revision.Sep 15 2021, 5:24 PM
olasd created this revision.
site-modules/profile/templates/hedgedoc/hedgedoc.service.erb
2 ↗(On Diff #22719)

lol, i see some people knows how to stay humble ;)

41 ↗(On Diff #22719)

Where does this variable come from?
I don't see them in the manifest calling this template.

One question inline.

Also, I'm not completely sure what entails the change from present to latest for the
node stack packages...

Otherwise, that looks rather good to me.

Thanks

site-modules/profile/templates/hedgedoc/hedgedoc.service.erb
41 ↗(On Diff #22719)

It comes from the manifest calling this template (profile::hedgedoc, line 20).

Also, I'm not completely sure what entails the change from present to latest for the
node stack packages...

The node package needs an update for hedgedoc 1.9.0 to work.

Also, I'm not completely sure what entails the change from present to latest for the
node stack packages...

The node package needs an update for hedgedoc 1.9.0 to work.

yes, i understood that but i meant the other packages in the array.
Well, if there is no risk then moving along.

ardumont added inline comments.
site-modules/profile/templates/hedgedoc/hedgedoc.service.erb
41 ↗(On Diff #22719)

oops, yeah, sorry, i expected it to show up in the diff somehow.
Thanks.

This revision is now accepted and ready to land.Thu, Sep 16, 10:21 AM