Page MenuHomeSoftware Heritage

HgLoaderFromDisk: Rename 'swhid' to 'sha1git' in variable names
ClosedPublic

Authored by vlorentz on Tue, Mar 30, 9:53 AM.

Details

Summary

SWHID has a specific meaning defined in https://docs.softwareheritage.org/devel/swh-model/persistent-identifiers.html
(in short, the sha1_git is only part of a SWHID), but this variables store
only the hash part of the SWHIDs.

Diff Detail

Repository
rDLDHG Mercurial loader
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Build is green

Patch application report for D5380 (id=19268)

Could not rebase; Attempt merge onto f5e96a7e3f...

Updating f5e96a7..d35b269
Fast-forward
 swh/loader/mercurial/from_disk.py | 48 ++++++++++++++++++---------------------
 1 file changed, 22 insertions(+), 26 deletions(-)
Changes applied before test
commit d35b2692b5f595b7bc545a286dea51d23b242606
Author: Valentin Lorentz <vlorentz@softwareheritage.org>
Date:   Tue Mar 30 09:53:06 2021 +0200

    HgLoaderFromDisk: Rename 'swhid' to 'sha1git' in variable names
    
    SWHID has a specific meaning defined in https://docs.softwareheritage.org/devel/swh-model/persistent-identifiers.html
    (in short, the sha1_git is only part of a SWHID), but this variables store
    only the hash part of the SWHIDs.

commit fd8e5fed4851140af5052ad34026891d8f9fd6c3
Author: Valentin Lorentz <vlorentz@softwareheritage.org>
Date:   Tue Mar 30 09:48:33 2021 +0200

    HgLoaderFromDisk: Fix typo in type annotation

See https://jenkins.softwareheritage.org/job/DLDHG/job/tests-on-diff/198/ for more details.

This revision is now accepted and ready to land.Tue, Mar 30, 10:44 AM