If you have the time to do the small refactoring about the api redundancy, please do it.
Otherwise, this seems good to go so accepted.
I see those same (or equivalent) snippets in swh.storage.api.client.RemoteStorage, swh.objstorage.api.client.RemoteObjStorage.
Can't we factorize those methods (url, post, get seems new) say in a base class somewhere?
Maybe explicit that this is to be called when the directory is cooked.