- rDSTO Storage manager
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.
If you have the time to do the small refactoring about the api redundancy, please do it.
Otherwise, this seems good to go so accepted.
I see those same (or equivalent) snippets in swh.storage.api.client.RemoteStorage, swh.objstorage.api.client.RemoteObjStorage.
Can't we factorize those methods (url, post, get seems new) say in a base class somewhere?
Maybe explicit that this is to be called when the directory is cooked.
Rename method to make it more explicit
get_directory was misleading as in only concern cooked directory.
As the endpoint is already GET/POST-specific, this enlightment is needed.
ah yes, nice catch, bytes won't pass with celery without adding some extra converters ^^