Page MenuHomeSoftware Heritage

Rename PackageInfo.raw to PackageInfo.raw_info and remove it from BasePackageInfo.
ClosedPublic

Authored by vlorentz on Fri, Jul 24, 2:00 PM.

Details

Summary

The rename is to disambiguate with 'raw metadata', which may differ from the
raw info.
And the base PackageLoader doesn't need to access this field, so removing
it from BasePackageInfo.

Diff Detail

Repository
rDLDBASE Generic VCS/Package Loader
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

vlorentz created this revision.Fri, Jul 24, 2:00 PM

Build is green

Patch application report for D3612 (id=12714)

Rebasing onto 14f700d0fa...

Current branch diff-target is up to date.
Changes applied before test
commit ec522be394ebe8eefd489a85e21a3d7ac593851d
Author: Valentin Lorentz <vlorentz@softwareheritage.org>
Date:   Fri Jul 24 14:00:17 2020 +0200

    Rename PackageInfo.raw to PackageInfo.raw_info and remove it from BasePackageInfo.
    
    The rename is to disambiguate with 'raw metadata', which may differ from the
    raw info.
    And the base PackageLoader doesn't need to access this field, so removing
    it from BasePackageInfo.

See https://jenkins.softwareheritage.org/job/DLDBASE/job/tests-on-diff/213/ for more details.

ardumont accepted this revision.Fri, Jul 24, 3:32 PM
This revision is now accepted and ready to land.Fri, Jul 24, 3:32 PM