Page MenuHomeSoftware Heritage

docker-dev: Use loader-package implems from swh.loader.core modules
ClosedPublic

Authored by ardumont on Nov 19 2019, 2:33 PM.

Details

Summary

This also removes the potential [1] breaking of the different services (referencing the old task names without the module installed)

[1] I did not see it in the earlier diff (D2304).

I also did not yet tested it entirely (in-progress, that should not prevent from merging as it stabilizes a bit more already).
Now swh-loader image starts.

Related T1389

Diff Detail

Repository
rCDFD Dockerfiles for developers
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

ardumont created this revision.Nov 19 2019, 2:33 PM
ardumont retitled this revision from docker-dev: Use loader-package implems from swh.loader.core modules to [wip] docker-dev: Use loader-package implems from swh.loader.core modules.Nov 19 2019, 2:38 PM
ardumont edited the summary of this revision. (Show Details)
ardumont edited the summary of this revision. (Show Details)
ardumont edited the summary of this revision. (Show Details)
ardumont added inline comments.Nov 19 2019, 2:42 PM
Dockerfile
35

It was implicitely installed as a dependency of other dvcs loaders.
Better be explicit about it now that it's a direct dependency for package loaders.

ardumont updated this revision to Diff 7941.Nov 19 2019, 2:56 PM

Remove some more old references which prevented the loader service to start

ardumont edited the summary of this revision. (Show Details)Nov 19 2019, 2:58 PM
ardumont added a project: Docker environment.
douardda accepted this revision.Nov 19 2019, 3:03 PM
This revision is now accepted and ready to land.Nov 19 2019, 3:03 PM
ardumont retitled this revision from [wip] docker-dev: Use loader-package implems from swh.loader.core modules to docker-dev: Use loader-package implems from swh.loader.core modules.Nov 19 2019, 3:05 PM
ardumont edited the summary of this revision. (Show Details)