Page MenuHomeSoftware Heritage

Dockerfile: Pin gunicorn version
ClosedPublic

Authored by anlambert on Nov 12 2019, 2:50 PM.

Details

Summary

Fresh 20.0.0 release of gunicorn broke the wsgi application factory feature (see https://github.com/benoitc/gunicorn/issues/2159).

So pin gunicorn to version 19.9.0 until the issue gets fixed upstream.

Related to T2080

Diff Detail

Repository
rCDFD Dockerfiles for developers
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

anlambert created this revision.Nov 12 2019, 2:50 PM
olasd accepted this revision.Nov 12 2019, 2:53 PM
olasd added a subscriber: olasd.

Can you please make this 'gunicorn<20' instead so we still get potential updates to the 19.x branch?

This revision is now accepted and ready to land.Nov 12 2019, 2:53 PM
anlambert updated this revision to Diff 7777.Nov 12 2019, 2:56 PM

Rebase and update commit message

This revision was automatically updated to reflect the committed changes.