Page MenuHomeSoftware Heritage

Latest versions on Pypi are an incompatible combination
Closed, ResolvedPublic

Description

Hi all.

Doing a pip install -U swh.model swh.scanner results in installing swh.model==2.0.0 and swh.scanner==0.3.0 (among others), which are not compatible. Going back to swh.model==0.11.0 makes scanner work again.

Event Timeline

zvr created this object in space S1 Public.
zack triaged this task as High priority.Mar 8 2021, 3:26 PM
zack added subscribers: vlorentz, zack.

@vlorentz: can you have a look at this? it's related to the recent changes around the CoreSWHID class, maybe just a release of swh-scanner is missing

vlorentz raised the priority of this task from High to Unbreak Now!.

Indeed it just needs a new release; but I need D5216 to fix the CI first

The issue should be fixed now