Page MenuHomeSoftware Heritage

Use python-cassandra 3.21
Closed, ResolvedPublic

Description

swh-storage can currently use only python-cassandra 3.19 and 3.20 because earlier versions didn't yet support Cassandra 4.0, and version 3.21 doesn't either because of a bug.

However, we want to use version 3.21 because it's the first one to provide wheels on PyPI, and build time without wheels is very long.

https://datastax-oss.atlassian.net/browse/PYTHON-1205

Event Timeline

vlorentz triaged this task as Normal priority.Feb 4 2020, 3:24 PM
vlorentz created this task.