Page MenuHomeSoftware Heritage

Archive graphs: vertical axis scaling not optimal
Closed, ResolvedPublic

Description

The graphs on https://www.softwareheritage.org/archive/ use the same Y-axis scaling.
The values chosen are only optimal for the first graph though, which causes the second and third ones to appear flat.

Event Timeline

ftigeot triaged this task as High priority.Aug 9 2019, 10:38 AM
ftigeot created this task.
ftigeot changed the task status from Open to Work in Progress.Aug 9 2019, 10:40 AM

This could be caused by the Javascript framework used to create graphs, Flot -- https://www.flotcharts.org/

When resizing the browser window or when loading the page the first time after having pasted its name in the URL bar, it is obvious the "Source files" data is used for all graphs.

Different data is only displayed for "Commits" and "Projects" graphs when clicking on the "archive" link from another web page or when forcing a page reload.

ftigeot closed this task as Resolved.Aug 9 2019, 2:35 PM
ftigeot claimed this task.

The yaxis scale was explicitly forced to begin at zero.
Removing that constraint allows the graphs to scale and fill their allocated vertical space.

Commit: rMWGND0805a1178fc4 .