Page MenuHomeSoftware Heritage

Prometheus rate functions considered unreliable
Closed, WontfixPublic

Description

With the right (unlucky) choice of time interval, some graphs based on the Prometheus rate() and irate() functions flatline to zero.

It is known problem.

One member of the Prometheus community, Alin Sînpălean, has extensively documented it in this bug report:

And attempted to provide a fix in this pull request:

At least one of the original Prometheus authors argued this was not a bug but the intended behavior and refused to pull fixes.
Alin Sînpălean ended up forking Prometheus and is now maintaining a fork at this location:
https://github.com/free/prometheus/releases

The fork provides new, more reliable functions such as xrate() and xdelta() but is otherwise identical to Prometheus itself.

Related Objects

Event Timeline

ftigeot triaged this task as Normal priority.Apr 16 2019, 4:55 PM
ftigeot created this task.
ftigeot closed this task as Wontfix.Nov 8 2019, 11:43 AM
ftigeot claimed this task.

No relevant problem has been reported with our dataset/usage of Prometheus. Closing.