Page MenuHomeSoftware Heritage

Create a dedicated logstash VM
Closed, ResolvedPublic

Description

The existing logstash instance on banco.internal.softwareheritage.org is unable to filter Apache logs it receives. Using a more recent version seems to be a good idea.
Moving away the logstash service to a different host will also free up resources on banco.

Event Timeline

ftigeot changed the task status from Open to Work in Progress.Jul 27 2018, 4:58 PM
ftigeot closed this task as Resolved.Jul 31 2018, 2:38 PM

A 6.3.x version of logstash is now running on logstash0.internal.softwareheritage.org , a brand new VM created on Proxmox/louvre.

The logstash.internal.softwareheritage.org CNAME now points to it and the service puts new data in Elasticsearch indexes as intended.