Page MenuHomeSoftware Heritage

Adapt the debian security repository release for bullseye distribution
ClosedPublic

Authored by vsellier on Thu, Sep 9, 3:17 PM.

Diff Detail

Repository
rSPSITE puppet-swh-site
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

vsellier created this revision.

Nice catch "For bullseye, the security suite is now named bullseye-security..." [1]

We still have one desktop (puppet managed) which is a debian stretch. I don't know
whether that's a blocking point or not, just mentioning it as it will fail [2]

I've recently added it to the vagrant list of nodes but I don't recall whether that's
provisioning completely or not (i added it because i needed it to check something)

[1] https://www.debian.org/News/2021/20210814

[2]

$ ssh giverny.internal.softwareheritage.org lsb_release -c
Codename:       stretch

[3] octo is not happy.

Error: Failed to compile catalog for node giverny.softwareheritage.org: Evaluation Error: Error while evaluating a Function Call, Unsupported debian version stretch (file: /tmp/ocd-ipc-20210909-14940-1g0za7a/ocd-builddir-20210909-14945-1p91xwk/environments/production/site-modules/profile/manifests/swh/apt_config.pp, line: 53, column: 9) on node giverny.softwareheritage.org
*** End octocatalog-diff on giverny.softwareheritage.org

ensure it works with stretch and versions >= bullseye

This revision is now accepted and ready to land.Thu, Sep 9, 5:08 PM