Page MenuHomeSoftware Heritage

django: Add support for Django 4.x
ClosedPublic

Authored by anlambert on Tue, Jul 12, 12:00 PM.

Details

Summary

Currently adding Django 4.x support to swh-web, swh-auth needs
also some adaptations to support both Django 2.2.x and Django 4.x.

Diff Detail

Repository
rDAUTH Common authentication libraries
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Build is green

Patch application report for D8112 (id=29303)

Rebasing onto cf6397a0ef...

Current branch diff-target is up to date.
Changes applied before test
commit a5b0f4dc8e7c5b0d8bcb3dc5e162316e57afe051
Author: Antoine Lambert <anlambert@softwareheritage.org>
Date:   Tue Jul 12 11:57:46 2022 +0200

    django: Add support for Django 4.x

See https://jenkins.softwareheritage.org/job/DAUTH/job/tests-on-diff/93/ for more details.

This revision is now accepted and ready to land.Tue, Jul 12, 12:22 PM
This revision was automatically updated to reflect the committed changes.