Page MenuHomeSoftware Heritage

cypress: Upgrade to 8.0 and fix flaky test
ClosedPublic

Authored by anlambert on Tue, Jul 20, 3:04 PM.

Details

Summary

D5982 did not fix the flaky cypress test.

Removing cy.intercept hack required some times ago seems
to do the trick.

Let's trigger a couple of Jenkins builds to be sure before landing this.

Diff Detail

Repository
rDWAPPS Web applications
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Build is green

Patch application report for D6008 (id=21700)

Rebasing onto c5d441b1a8...

Current branch diff-target is up to date.
Changes applied before test
commit 914c19e314c7fd39eb6c6bf43bbad7d6430fe14c
Author: Antoine Lambert <anlambert@softwareheritage.org>
Date:   Tue Jul 20 15:03:01 2021 +0200

    cypress: Upgrade to 8.0 and fix flaky test
    
    D5982 did not fix the flaky cypress test.
    
    Removing cy.intercept hack required some times ago seems
    to do the trick.

See https://jenkins.softwareheritage.org/job/DWAPPS/job/tests-on-diff/975/ for more details.

Build is green

Patch application report for D6008 (id=21700)

Rebasing onto c5d441b1a8...

Current branch diff-target is up to date.
Changes applied before test
commit 914c19e314c7fd39eb6c6bf43bbad7d6430fe14c
Author: Antoine Lambert <anlambert@softwareheritage.org>
Date:   Tue Jul 20 15:03:01 2021 +0200

    cypress: Upgrade to 8.0 and fix flaky test
    
    D5982 did not fix the flaky cypress test.
    
    Removing cy.intercept hack required some times ago seems
    to do the trick.

See https://jenkins.softwareheritage.org/job/DWAPPS/job/tests-on-diff/976/ for more details.

Build is green

Patch application report for D6008 (id=21700)

Rebasing onto c5d441b1a8...

Current branch diff-target is up to date.
Changes applied before test
commit 914c19e314c7fd39eb6c6bf43bbad7d6430fe14c
Author: Antoine Lambert <anlambert@softwareheritage.org>
Date:   Tue Jul 20 15:03:01 2021 +0200

    cypress: Upgrade to 8.0 and fix flaky test
    
    D5982 did not fix the flaky cypress test.
    
    Removing cy.intercept hack required some times ago seems
    to do the trick.

See https://jenkins.softwareheritage.org/job/DWAPPS/job/tests-on-diff/977/ for more details.

Build was aborted

Patch application report for D6008 (id=21700)

Rebasing onto c5d441b1a8...

Current branch diff-target is up to date.
Changes applied before test
commit 914c19e314c7fd39eb6c6bf43bbad7d6430fe14c
Author: Antoine Lambert <anlambert@softwareheritage.org>
Date:   Tue Jul 20 15:03:01 2021 +0200

    cypress: Upgrade to 8.0 and fix flaky test
    
    D5982 did not fix the flaky cypress test.
    
    Removing cy.intercept hack required some times ago seems
    to do the trick.

Link to build: https://jenkins.softwareheritage.org/job/DWAPPS/job/tests-on-diff/978/
See console output for more information: https://jenkins.softwareheritage.org/job/DWAPPS/job/tests-on-diff/978/console

The diff seems to fix the previously observed flaky test but got bitten by another one which does not happen so often thanks to cypress retry features.

14:17:31    1) Test Content Language Select
14:17:31         When language is switched from dropdown
14:17:31           should contain argument with language in url:
14:17:31       AssertionError: Timed out retrying after 20000ms: expected '?origin_url=https://github.com/memononen/libtess2&path=premake4.lua' to include 'language=lua'
14:17:31        at Context.eval (http://localhost:5004/__cypress/tests?p=cypress/integration/language-select.spec.js:353:29)

I am going to land this and will hunt the flaky test above later if it comes back.

This revision was not accepted when it landed; it landed in state Needs Review.Tue, Jul 20, 4:27 PM
This revision was automatically updated to reflect the committed changes.