Page MenuHomeSoftware Heritage

requirements-swh.txt: Use >= instead of == for swh-core version check
ClosedPublic

Authored by anlambert on Tue, Mar 17, 3:39 PM.

Details

Summary

This fixes installation of swh modules in virtualenv when executing $ pip install $(./bin/pip-swh-packages) in swh-environment.

The following error is reported otherwise and all modules get uninstalled afterwards.

ERROR: swh-storage 0.0.178 has requirement swh.core[db,http]==0.0.94, but you'll have swh-core 0.0.94.post1 which is incompatible.

Diff Detail

Repository
rDSTO Storage manager
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

anlambert created this revision.Tue, Mar 17, 3:39 PM
vlorentz accepted this revision.Tue, Mar 17, 3:42 PM
This revision is now accepted and ready to land.Tue, Mar 17, 3:42 PM
This revision was landed with ongoing or failed builds.Tue, Mar 17, 3:43 PM
This revision was automatically updated to reflect the committed changes.