Page MenuHomeSoftware Heritage

Rename 'cursor' to 'scroll_token'.
ClosedPublic

Authored by vlorentz on Mon, Oct 28, 1:53 PM.

Details

Summary

'cursor' has a different meaning in our components using postgresql;
this renaming will avoid confusion when adding token-based pagination
to these components.

Diff Detail

Repository
rDSEA Archive search
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

vlorentz created this revision.Mon, Oct 28, 1:53 PM
vlorentz updated this revision to Diff 7439.Mon, Oct 28, 1:56 PM

remove TODO

olasd accepted this revision.Tue, Oct 29, 1:35 PM
olasd added a subscriber: olasd.
olasd added inline comments.
swh/search/elasticsearch.py
116–117

This sentence is missing word.

This revision is now accepted and ready to land.Tue, Oct 29, 1:35 PM
vlorentz updated this revision to Diff 7460.Tue, Oct 29, 1:41 PM

fix typo

This revision was landed with ongoing or failed builds.Tue, Oct 29, 1:41 PM
This revision was automatically updated to reflect the committed changes.